Hello, i'm almost afraid to ask but will give it a go seeing as you seem to be the only bloke with the right answers.
I haven't been able to get the guestbook working for a long time now and after an exhausting night of dedicated search I still cannot find any proper help to get this mod working.
I have had it working on earlier versions of WebApp and consider it is definately the nicest guestbook i've seen. I want it back. I'm happy to work on it if that's what I need to do but I have no idea where to start.
I run the install and it says that it sets all permissions correctly. I double-check to make sure that it did what it said. I click create config file in WebApp mods and it lets me create a config.
I type in guestbook
then 4
then set admin script to 1
then set language to 1
I leave Guestbook Mod for WebAPP in the bottom box and then I click Edit config file again and return to the Mod Manager.
I click Guestbook Admin and get a server error... grrr.
Is it me? What have I done wrong or what do I need to do next?
Have you made sure to upload the files in ASCII mode? and is the correct path to perl set in your scripts? You can also check the error logs for your server and find out exactly what is causing the error. Good place to start. Good Luck.
Pete wrote: Hello, i'm almost afraid to ask but will give it a go seeing as you seem to be the only bloke with the right answers.
I haven't been able to get the guestbook working for a long time now and after an exhausting night of dedicated search I still cannot find any proper help to get this mod working.
I have had it working on earlier versions of WebApp and consider it is definately the nicest guestbook i've seen. I want it back. I'm happy to work on it if that's what I need to do but I have no idea where to start.
I run the install and it says that it sets all permissions correctly. I double-check to make sure that it did what it said. I click create config file in WebApp mods and it lets me create a config.
I type in guestbook
then 4
then set admin script to 1
then set language to 1
I leave Guestbook Mod for WebAPP in the bottom box and then I click Edit config file again and return to the Mod Manager.
I click Guestbook Admin and get a server error... grrr.
Is it me? What have I done wrong or what do I need to do next?
He who chases his dreams and wishes, Yet never sets any goals, Will never know if he catches them.
Thanks for a lightning reply. I have since refreshed all files and was sure to set ASCII mode. I have checked all perl paths are correct. I've started using Win32Pad and notice that all Guestbook files in the download are in DOS/WIN format instead of unix and am wondering if this could be the problem now? since that is what fixed the latest WebApp.
I then re-saved all data files as UNIX and uploaded again. This has not fixed it either. If anyone knows this script, I'd love to hear what to try next.
At one stage, I got to the point where the guestbook was working but not the admin. When I went to the guestbook.cgi url, it said "you must add a message". I tried to go admin but got the dreaded internal error.
After 24 hours (10 hours of concerted efforts), trying all sorts, I have given up... for now... I do have a fresh working version of the new WebAPP installed, if you can get the guestbook to work with that version, I'd be over the moon (and very impressed).
I eagerly look forward to your results.
As an addendum; I also installed your menu manager edit, got it working but somehow messed up all of my menu's. I spent a while trying to get them back but couldn't work out the code. Ended up removing the mod but the menu writing was still lost. I replaced the language file and all was okay again but still minus the menuman...
It's putting an extra "enter" in the header and causing a page fault. After much research, I finally found it was the way WebAPP files itself was saved. (they were in DOS/WINDOWS format as opposed to UNIX). I'm thinking is it possible your edits may be the same?
I use freeware Win32pad which gives you the option of saving text files in either format. If you can't find it, you will at http://www.gena01.com/win32pad/
Damn, still getting an internal error on the admin after I set it up. I'm still playing but you said to give it 15 mins and it's been 30 so far, Thought I'd report in.
This web site was made with WebAPP v0.9.9.3.3 , a web portal system written in Perl
All trademarks and copyrights on this page are owned by their
respective owners. Comments are owned by the Poster.